Excel : numéro de semaine incorrect

Problème

J’utilise la fonction Excel NO.SEMAINE pour déterminer en quelle semaine nous nous trouvons. Certaines années, Excel se trompe, notamment en 2009 et 2010 et j’obtiens un décalage d’une semaine. Cela est du au fait qu’Excel ne calcule pas la semaine à partir de la première semaine de 4 jours de l’année mais à partir du 1er janvier.

Solution

Pour contourner cette erreur, il faut utiliser la formule suivante : =SI(A1<> » »;ENT((A1-SOMME(MOD(DATE(ANNEE(A1-MOD(A1-2;7)+3);1;2);{1E+99;7})*{1;-1})+5)/7); » »)

En considérant que la cellule A1 contienne la date dont on veut déduire la semaine.

Source : http://fr.wikipedia.org/wiki/Num%C3%A9rotation_ISO_des_semaines  

REMARQUE: pour activer les arguments de la fonction « NO.SEMAINE » il faut activer une macro complémentaire dans Outils /Macro Complémentaire  et selectionner « Utilitaire d’analyse » Complément d’information sur http://office.microsoft.com/fr-fr/excel-help/no-semaine-fonction-HP010343016.aspx